Page 1 of 2 12 LastLast
Results 1 to 15 of 21

Thread: 1991 SC brake booster seems to charge a lot

  1. #1
    Join Date
    Nov 2012
    Location
    Canton, GA
    Posts
    358

    1991 SC brake booster seems to charge a lot

    Hey,
    Iím fixing up my 1991 SC and it should be roadworthy soon, but I am a little concerned about the brakes. Sometimes, the car can be on or running for 1-2 minutes before the brake booster begins to charge. Now, to be fair, it only did this a few times after not starting the car for like 4-5 months and it seems to come on right away ever since. However, if I turn the car on for the first time in a day, it takes almost a full minute for it to charge. If I turn off the car and turn it on again 30 minutes later, it takes maybe 15 seconds to charge (but this seems long if the car just got charged less than an hour ago).

    This seems weird to me because my 1990 brake booster would usually only charge 15-30 seconds for the first time in a day and only charge for maybe 10 seconds if I restarted the car 2 hours later. Im estimating the times, but it really seems like my 1991 spends a lot more time charging its brakes than my 1990, even when it seems like the brakes were just charged a short while ago. The accumulator ball was new in 2013 and the car has not been driven since 2015 (I do start the engine every couple of months and move it up and down the driveway).


    Iíve driven my 1990 SC a lot and itís entire brake booster was rebuilt by Supercoupe Performance, so it seems like a good baseline for what a healthy brake booster should act like. Am I leaking pressure or is perhaps a sensor worn out? Just wondering if anyone else had this same issue/concern.

  2. #2
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,378
    If you mean the accumulator, I find that a new/good unit will charge in 25 ~ 40 seconds. This assumes adequate voltage to a healthy hyd/pump.

    As for the 15 seconds on restart, keep in mind the light comes on during self-test.

    When they get old/weak, they take longer.

    Accumulators are replaced, not rebuilt, BTW. A rebuilt assembly would assume to mean a new accumulator, new pump, w/clean wiring/connectors.

  3. #3
    Join Date
    Nov 2012
    Location
    Canton, GA
    Posts
    358
    Quote Originally Posted by KMT View Post
    If you mean the accumulator, I find that a new/good unit will charge in 25 ~ 40 seconds. This assumes adequate voltage to a healthy hyd/pump.

    As for the 15 seconds on restart, keep in mind the light comes on during self-test.

    When they get old/weak, they take longer.

    Accumulators are replaced, not rebuilt, BTW. A rebuilt assembly would assume to mean a new accumulator, new pump, w/clean wiring/connectors.
    Thanks for the reply.
    I should specify that the 1991 had it's accumulator ball replaced in the Spring/Summer of 2013, but the brake booster and everything else was otherwise left alone. The 1991 has not driven on a public road since I bought my 1990 Spring of 2015.

    My 1990 had it's brake booster rebuilt in the spring of 2015 and it got a new accumulator ball. We paid for the service from Supercoupe Performance and had the whole unit shipped off and shipped back. My 1990's brakes are the standard against which I'm comparing the 1991's brakes to.


    Can an accumulator ball get weaker in 7 years with relatively little use? The brakes do work, but I am wondering what I should do to make sure everything is safely in order before fully trusting it on the road. Can I do an ABS test/collect codes with the little plug with a red cap (which I believe is in the trunk) like I can do an OBD-1 test and collect codes with the gray plug under the hood?
    Last edited by Rick_Leuce; 04-06-2020 at 10:13 PM.

  4. #4
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,378
    Quote Originally Posted by Rick_Leuce View Post
    I should specify that the 1991 had it's accumulator ball replaced in the Spring/Summer of 2013, but the brake booster and everything else was otherwise left alone. The 1991 has not driven on a public road since I bought my 1990 Spring of 2015.
    The stock ABS did not use a 'booster'. If this is about doing a conversion to a booster equipped brake system, then you no longer have an accumulator. I'm only talking about an accumulator, so feel free to ignore.
    Can an accumulator ball get weaker in 7 years with relatively little use?
    I'd expect some loss, yes. The nitrogen bladder doesn't last forever and quality of units can differ, along with how long they may have sat around before being put into use. Migration of the gas past the membrane happens. The last new one I put in my car has 6 years on it, low miles and takes 35~40 seconds to pressurize after sitting 2 weeks. When it hits one minute + and the light comes on after less than 5 pedal pushes I'll consider finding a new one.

    Can I do an ABS test/collect codes with the little plug with a red cap (which I believe is in the trunk) like I can do an OBD-1 test and collect codes with the gray plug under the hood?
    Sure, search here for details, and/or duffy's article. All been discussed before.

    Personally, I'd be more concerned about the effects of corrosion on the harness over that time, but that's just me

    If you're worried, don't drive it.

  5. #5
    Join Date
    Nov 2012
    Location
    Canton, GA
    Posts
    358
    Thanks you for clarifying a few things. Iíve mistakenly referred to my ABS unit as a brake booster for years. Its a regular stock 1989-1992 system with a new-ish accumulator ball. I will say that I am happy my 1993 has a regular boring non-accumulator ball brake booster. Maybe someday Iíll consider converting my 1991 or 1990 to using a 1993+ system, but not right now.

    Iíll try checking the harness. My 1990 was acting up almost a year ago. The brakes wouldnít charge at all for several minutes. Then I noticed how corroded the ground bolt was. I cleaned the ground bolt, covered it in dialectic grease, and it didn't give me any problems all the way to Wisconsin. It did hesitate once after starting; it took maybe 5-10 seconds before it began charging from the time I turned the key, but it never did it again.

  6. #6
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,753
    Quote Originally Posted by Rick_Leuce View Post
    Thanks you for clarifying a few things. Iíve mistakenly referred to my ABS unit as a brake booster for years.
    No mistake. It is a brake booster+ABS unit assembly. It does 2 jobs.

    Quote Originally Posted by Rick_Leuce View Post
    It did hesitate once after starting; it took maybe 5-10 seconds before it began charging from the time I turned the key, but it never did it again.
    Sometimes as well, when they sit for long periods of time, the build of of old residue, from old fluid in the pump, will cause the motor to bind.. eventually, it overcomes it and starts to spin. Its why its best to star/run all of these cars regularly.

  7. #7
    Join Date
    Oct 2003
    Location
    Allentown, PA
    Posts
    962
    This ABS pump was working when it was rebuilt.
    Name:  IMG950755.jpg
Views: 87
Size:  150.1 KB

    Alot of PB Blaster did the job. More info
    J.Miller
    1990 XR7 and 1955 F250!

  8. #8
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,378
    Quote Originally Posted by TbirdSCFan View Post
    No mistake. It is a brake booster+ABS unit assembly. It does 2 jobs..
    Yes, there is a mechanical 'booster' component to the Teves system. I push back because of occasional comments here that say 'booster' meaning they've removed the Teves and converted to a standard system that employees a vacuum booster, as an example, and I don't want to have to stop and suss which way the thread might go

    Don't get me started on struts...

    Ken

  9. #9
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,753
    Quote Originally Posted by KMT View Post
    Yes, there is a mechanical 'booster' component to the Teves system. I push back because of occasional comments here that say 'booster' meaning they've removed the Teves and converted to a standard system that employees a vacuum booster, as an example, and I don't want to have to stop and suss which way the thread might go

    Don't get me started on struts...

    Ken
    Yeah. The terms have been tossed around a lot. Of course, with our beloved SuperCoupes aging like they have, there's fewer of them running these days.. So anyone working hard to keep one road worthy, is a special kind of fool, like me! LOL

    I have, through tenacity, and out-and-out stubborness, kept my TevesII operating on all 3 of my SCs.

  10. #10
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,753
    Quote Originally Posted by J dot Miller View Post
    This ABS pump was working when it was rebuilt.
    Name:  IMG950755.jpg
Views: 87
Size:  150.1 KB

    Alot of PB Blaster did the job. More info
    So that looks like par for the course.. what you're seeing is corrosion buildup from brake fluid seeping past the shaft seal. Its very common.. there is a thread, on here from mazza, where he spec'd a honda part that is the correct size. Although not the ideal rubber compound, they at least hold up for a few years. If you clean, rebuild and get a new seal, you should be able to get going again.

  11. #11
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,378
    Quote Originally Posted by TbirdSCFan View Post
    I have, through tenacity, and out-and-out stubborness, kept my TevesII operating on all 3 of my SCs.
    Feel the same, but only one to keep going here, making you a hero w/3

  12. #12
    Join Date
    Nov 2012
    Location
    Canton, GA
    Posts
    358

    Antilock light is on

    Despite turning on and running my 1991 SC more often than ever, the brakes are acting up again. This time, the ďAntilockĒ light was on and my pedal was hard. About two minutes later the light went away and the brakes worked normally again. I figure something is making it get gradually worse. Could this be a bad accumulator? If so, now isnt the worst time for me to buy a replacement. In 2015, I couldn't get one at all except for the fact that I got one as part of the rebuild.

  13. #13
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,378
    Yes, sounds like a typical example of a weak/failing/old accumulator. I've also seen this with corroded relay, and harness connectors.

    After the lights go out, how many pumps do you get on the pedal before it comes on again?

  14. #14
    Join Date
    Nov 2012
    Location
    Canton, GA
    Posts
    358
    Quote Originally Posted by KMT View Post
    Yes, sounds like a typical example of a weak/failing/old accumulator. I've also seen this with corroded relay, and harness connectors.

    After the lights go out, how many pumps do you get on the pedal before it comes on again?
    Thanks for the quick reply

    I get 4 brake pedal presses before the accumulator charges. I think I heard somewhere it should be 8-10 pedal presses.

    It takes 18-21 brake pedal presses while the car is running before the Antilock light comes on. Four times it was 18, twice it was 21, and five times it was 20.
    Last edited by Rick_Leuce; 04-13-2020 at 10:51 PM.

  15. #15
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,753
    Quote Originally Posted by Rick_Leuce View Post
    Thanks for the quick reply

    I get 4 brake pedal presses before the accumulator charges. I think I heard somewhere it should be 8-10 pedal presses.

    It takes 18-21 brake pedal presses while the car is running before the Antilock light comes on. Four times it was 18, twice it was 21, and five times it was 20.
    Well more is certainly better, but that's actually good. Its when it hits 2 that you need to think about replacing the accumulator.

Similar Threads

  1. 94 SC brake booster with master cylinder
    By lineboy55 in forum Parts for Sale
    Replies: 0
    Last Post: 01-18-2010, 01:28 PM
  2. Thunderbird SC ABS system brake booster master cylinder
    By dragthestang in forum Parts for Sale
    Replies: 0
    Last Post: 02-25-2005, 06:00 AM
  3. Thunderbird SC ABS system brake booster master cylinder
    By dragthestang in forum Parts for Sale
    Replies: 4
    Last Post: 02-13-2005, 10:58 PM
  4. Crap, main bearings dont seem to match up on SC cr
    By DMX in forum Technical Forum
    Replies: 6
    Last Post: 08-21-2003, 04:31 PM
  5. Need '91 SC Brake Booster
    By BobD in forum Technical Forum
    Replies: 2
    Last Post: 07-25-2002, 11:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •