Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

Thread: 1991 SC brake booster seems to charge a lot

  1. #16
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,753
    And for anyone looking at alternatives for the shaft seal.. here's an old thread.

    http://www.sccoa.com/forums/showthre...tor+shaft+seal

  2. #17
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,382
    Quote Originally Posted by Rick_Leuce View Post
    I get 4 brake pedal presses before the accumulator charges.
    4 pumps is marginal. 6 or less is usually when I start shopping for a new one.

    Sorry if I missed it, do you have any idea just how old that accumulator is?

    five times it was 20.
    Sounds like you're safe in that case, as long as those are full, firm pumps.

  3. #18
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    21,117
    Quote Originally Posted by KMT View Post
    Yes, sounds like a typical example of a weak/failing/old accumulator. I've also seen this with corroded relay, and harness connectors.

    After the lights go out, how many pumps do you get on the pedal before it comes on again?
    I also had the same thing happening and it ended up being a bad relay. The relay worked well enough to switch the motor/pump on for recharging the accumulator but would kick out when load increased and before accumulator was fully charged resulting in much more frequent charging cycle, until eventually it would just click on and off without charging the accumulator. Replacing the relay fixed it. About a year or two later I also replaced the accumulator, just because it was original.

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat.............10.597 @ 135.78

    My Garage

  4. #19
    Join Date
    Nov 2012
    Location
    Canton, GA
    Posts
    360
    Quote Originally Posted by KMT View Post
    4 pumps is marginal. 6 or less is usually when I start shopping for a new one.

    Sorry if I missed it, do you have any idea just how old that accumulator is?



    Sounds like you're safe in that case, as long as those are full, firm pumps.
    We replaced the accumulator in 2013.

    Im starting to think that the relay could be my issue; I may need to order another one. But I may order a spare accumulator just to have; one of my Supercoupes should need it soon.

  5. #20
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,382
    Quote Originally Posted by David Neibert View Post
    I also had the same thing happening and it ended up being a bad relay.
    I had a new accumulator on order, and a good spare pump on the bench, when I found the relay and it's connector greened up to no end. Replaced the relay and connector, canceled the order, put the pump back into storage, and the ABS has been happy for 2+ years since.

  6. #21
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,382
    Quote Originally Posted by Rick_Leuce View Post
    We replaced the accumulator in 2013.

    Im starting to think that the relay could be my issue; I may need to order another one. But I may order a spare accumulator just to have; one of my Supercoupes should need it soon.
    I waffle between buying a fresh accumulator when they become available, and not wanting one to waste from years unused. For now, I don't have a spare and hope taking chances doesn't bite me in the tailpipe.

    Relay is low hanging fruit, so...just be sure to lay eyes on it's connector, also the one with the hot leads/grnds. at the side of the master cylinder to confirm they're clean/snug. Tangs break easy, so be gentle.

Similar Threads

  1. 94 SC brake booster with master cylinder
    By lineboy55 in forum Parts for Sale
    Replies: 0
    Last Post: 01-18-2010, 01:28 PM
  2. Thunderbird SC ABS system brake booster master cylinder
    By dragthestang in forum Parts for Sale
    Replies: 0
    Last Post: 02-25-2005, 06:00 AM
  3. Thunderbird SC ABS system brake booster master cylinder
    By dragthestang in forum Parts for Sale
    Replies: 4
    Last Post: 02-13-2005, 10:58 PM
  4. Crap, main bearings dont seem to match up on SC cr
    By DMX in forum Technical Forum
    Replies: 6
    Last Post: 08-21-2003, 04:31 PM
  5. Need '91 SC Brake Booster
    By BobD in forum Technical Forum
    Replies: 2
    Last Post: 07-25-2002, 11:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •