Results 1 to 3 of 3

Thread: 95sc automatic randomly stalls when at stop or reverse- potential problem shooting?

  1. #1
    Join Date
    Mar 2020
    Location
    SK, Canada
    Posts
    10

    Question 95sc automatic randomly stalls when at stop or reverse- potential problem shooting?

    1995 Supercharger, v6 for reference:

    When at at stop the engine just suddenly gets quiet and usually her rmp drops a bit before and then the engine cuts out. Like the dash and everything still on so you have to 'turn the car off' then on again.

    When at a red light, and she starts to do that, if you put her in neutral she's okay and wont stall. (this is more frequent that she stalls in this manner)

    When I go to reverse, rpm goes down (normalish from what I understand because heavier load on engine) but sometimes she cuts out (not always but it's happened three times in the last five months).


    Her fuel is okay and was above a quarter tank each time. She starts up just fine, and has only puttered I think once and thats because I took my hand off the key too soon I think. I checked transmission fluid a while ago, and it's a reddish pink each time I look at it (after the engines ran a bit ofc).

    No check engine lights at any of the events listed. Based on research done so far, o2 sensor is my next suspect, but I wanted to bounce some ideas to make a checklist of sorts.

  2. #2
    Join Date
    Jul 2005
    Location
    Mississauga
    Posts
    1,008
    I find that with my '93 the rpm will do that. Summer problem. Try opening the windows and turning off the ac. When the ac cycles on it loads the engine. Maybe all you need to do is turn up the idle a bit.
    Alan

  3. #3
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,415
    Could be a number of things, from worn plugs, to vacuum leaks, to failing IAC, etc.

    Something you can try that won't cost more than a can of spray carb cleaner, is to remove the black rubber air intake tube off the throttle body, and then closely inspect the bore and throttle plate for black carbon-like build up. Use the spray cleaner and a lint free rag to wipe down/scrub the bore and plate, being sure to open the plate so you can get to any buildup on both sides of it and on the bore as far as you can reach/see. Reassemble when clean and monitor symptoms for improvement.

    Thanks for noting the MIL, but you still might want to read codes.

    As for the O2 sensors, I'm not sure they'd be suspect in this particular example, but...how many miles/years on them? They don't last forever, so this may be a good excuse to make new. Pro tip: if you do replace the O2 sensors, -don't- buy the cheapest ones you can find, and be wary of fake motorcraft parts/packaging.

    Good luck.
    Last edited by KMT; 06-30-2020 at 01:21 PM.

Similar Threads

  1. stalls at stops when hot
    By fomoco74mav in forum Technical Forum
    Replies: 8
    Last Post: 04-03-2013, 12:33 AM
  2. stalls at stops when hot
    By fomoco74mav in forum Technical Forum
    Replies: 1
    Last Post: 03-31-2013, 10:12 PM
  3. why is my car stalling when I stop?
    By rolltide in forum Technical Forum
    Replies: 17
    Last Post: 09-17-2003, 06:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •