Results 1 to 4 of 4

Thread: Low oil pressure/water temp reading

  1. #1
    Join Date
    Jun 2017
    Location
    Sweden
    Posts
    63

    Low oil pressure/water temp reading

    I have a 91 SC with low oil pressure reading and low temp reading. Have replaced both sending units but problem persists. I have checked the oil pressure with external gauge and it's fine. Same with temp, checked with infra red gun and reads about 190 deg at the base of sending unit. Engine runs fine with no issues or noise. Fuel gauge reads full no matter what. Cluster malfunctioning?

  2. #2
    Join Date
    May 2012
    Location
    Denver Area
    Posts
    949
    Sounds like grounds not working so well...

  3. #3
    Join Date
    Jun 2017
    Location
    Sweden
    Posts
    63
    That's what I fugured too, I'll have to check that somehow.

  4. #4
    Join Date
    Jun 2017
    Location
    Sweden
    Posts
    63
    Thanks for the input but problem solved. It was the circutboard to the right of the cluster that was not entirely in place and the wire from the oil pressure sending unit that was faulty. Replaced it with a new wire and everyting works fine.

Similar Threads

  1. Oil Pressure & Water temp
    By doug93sc in forum Technical Forum
    Replies: 3
    Last Post: 10-13-2006, 12:12 PM
  2. Replies: 11
    Last Post: 07-11-2005, 03:08 AM
  3. Low oil pressure during idle
    By rzibilske77 in forum Technical Forum
    Replies: 18
    Last Post: 06-10-2005, 09:31 PM
  4. Low oil pressure when coming to a stop!!
    By DirtySouthBird in forum Technical Forum
    Replies: 7
    Last Post: 02-15-2005, 08:46 PM
  5. Low Oil Pressure
    By 1QuikV6 in forum Technical Forum
    Replies: 9
    Last Post: 09-09-2004, 03:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •