Results 1 to 3 of 3

Thread: HELP! Replacing shift assembly for the first time.

  1. #1
    Join Date
    Oct 2002
    Location
    The Motor City, MI
    Posts
    17

    HELP! Replacing shift assembly for the first time.

    Has anyone ever replaced the shift assembly on a '90ish SC, 5-speed Mazda M5R2 trans before? (the only OE numbers I could pull from said assembly is SR502)

    I've taken out the 4 bolts underneath the boot and removed the old unit. Now, to reinstall with my new assembly is there a trick to lining up springs, linkage, etc?

    A bit of background on the issue: 2nd gear just wasn't cooperative. I could take off in 2nd and shift from 1st into 2nd at a very low RPM, but couldn't shift into 2nd at any other time without a horrid grind. I also had way too much play in the shifter, it was extremely sloppy. I knew there was an issue with the shifter, but today was clarified on just how serious the issue had become. I was stuck in 3rd gear and the shift assembly broke.

    Is the assembly the issue I should be concerned with or would you assume further problems?

    Thanks for any and all comments!

  2. #2
    Join Date
    Jan 2003
    Posts
    44

    Horrid grinding

    Sorry to say, but horrid grinding when shifting is usually caused by worn or damaged synchronizers. Internal. Yikes. Another possibility is the clutch not releasing completely, although it would affect shifting in all gears.

  3. #3
    Join Date
    Oct 2002
    Location
    The Motor City, MI
    Posts
    17

    shift plate?

    It's had this exact problem once before and I had the 'shift plate" replaced. Or at least I believe that's what it was. I'll have to double check exactly what corrected the problem. It was in a tranny shop so I didn't do the work myself. I do know that the guy had to make something because parts are no longer available for my Mazda trans.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •