Results 1 to 7 of 7

Thread: Finally got to drive my new SC, lacks power?

  1. #1
    Join Date
    Nov 2002
    Location
    Toms River, NJ 08753
    Posts
    218

    Finally got to drive my new SC, lacks power?

    I bought a 1994 SC 5 Spd, with 59k. I noticed that when I am in 5th gear and floor it, goint about 70+ the car seems to lack power, I glanced at my boost gauge and one time it was reading 10 and the other 8. I know she prob needs a tune up , but do you think I have a vacumn leak somewhere?? I listed to the SC and it sounds normal.

    I am comparing this to my 94 V8, that I had, if I floored it going about 70 she would take off, but the supercoupe seems to lack.

    Thanks for the info.

  2. #2
    Join Date
    Apr 2002
    Location
    Overland Park, KS
    Posts
    4,054
    The reason your '94 took off is becuase when you would hit the gas it would downshift. You need to do the same with the SC. 5th gear wasn't meant for power. It was designed for cruising and gas efficiency, pull it down into 3rd and hit it, and you will notice a BIG difference.

    Thomas

  3. #3
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,648
    You got somthin missing... 70 is just barely moving as far as the SC goes. You DO have to floor it though and get it to kick down into 3rd gear and out of OD. The OD band is so tall that the engine will bog. Once its out of OD though you'll find yourself backing off the throttle about as soon as you're on it. With your Eaton M90, you should be pulling around 11-12 lbs of boost when the engine gets wound up.
    I've not always liked that about the AOD tranny myself, and would rather drive around in "D". But don't do that... the AOD has a small main valve and was built to run in OD. If you start manually shifting it, you'll be rebuilding it because it will start slipping in the near future.

  4. #4
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,648
    And of course, after making my comments, I read that you have the 5 speed... Oh well, some else might get something out of it.

  5. #5
    Join Date
    Nov 2002
    Location
    NJ
    Posts
    1,024
    hmm, well I know in my car it takes off in all the gears but I must say 3rd really goes, I think I got to 80 and still had a little more to the red line and so does fourth, I would say change the plugs and wires.

  6. #6
    Join Date
    Nov 2002
    Location
    Toms River, NJ 08753
    Posts
    218

    Thanks guys

    Thanks guys for the input. I am still learing to drive a 5 spd. so that is prob. my fault. I am going to change the plugs and wires, its just been so freaking cold....brrrrrrr..

  7. #7
    Join Date
    Sep 2002
    Location
    Washington PA
    Posts
    2,517
    2nd gear should be good for 72mph and 3rd should be good for 116. At least in the 89-93 birds, not sure about the 94-95 models.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •