Results 1 to 4 of 4

Thread: Who has blown head gaskets using Fel-Pros?

  1. #1
    Bill A McNeil Guest

    Who has blown head gaskets using Fel-Pros?

    Wondering if this has happened to anyone and why.

  2. #2
    Join Date
    Oct 2012
    Posts
    36
    Quote Originally Posted by Bill A McNeil View Post
    Wondering if this has happened to anyone and why.
    I have. Don't know why. I'm swapping a 5.0 and selling my 3.8. I'll give you guys on here first dibs on it.

  3. #3
    Join Date
    Nov 2005
    Location
    Fort Wayne, Indiana
    Posts
    2,985
    LOL, I cant believe a random message like this was never replied to before now. only 13 years later. To answer it, with 17psi and some detonation, I lifted heads and was pushing some combustion into the cooling system with fel-pros. I believe I had a bit of head stud torque inaccuracies, and my heads were still stock on the combustion chamber side. I don't blame the gaskets, put it that way

    chris
    Last edited by mywhite89; 06-15-2015 at 05:52 PM.
    Me-89 SC 5-speed 1.7 Autorotor twin screw over 443rwhp 20psi
    Her-95 SC auto 1.7 KB 400rwhp 17psi
    my email

  4. #4
    Join Date
    Apr 2002
    Location
    Greenville, IN
    Posts
    4,255
    Since the thread is already resurrected...

    16psi on Felpro's w/ Arp head studs for 5 years and 20psi for 1yr so far and they're still holding just fine.
    Matt Haub
    Shootouts: '09 SS 1st | '10 Mod1 2nd | '11 Bracket 3rd | '12 Bracket 1st | 2013 | '14 Bracket 3rd | 2015 | '16 Bracket 1st & Mod2 2nd | 2017 |
    Black '89 5spd - 281K miles, MPx, E85, Alky-Inj RWHP: ? RWTQ: ? Best 1/4mi:12.521, MPH:107.23mph
    35th Anniversary Auto 46k miles | Red '93 Auto 186k miles
    My Garage

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •