Results 1 to 3 of 3

Thread: Crank Sensor Bad?

  1. #1
    Join Date
    Feb 2003
    Location
    Fremont, CA
    Posts
    3

    Crank Sensor Bad?

    I have a 92 SC and from all I've seen on this subject is just about every time a crank sensor goes out, the harminoc balancer is damaged beyond repair. In my case, the balancer, by visual inspection, appears to be OK. Did I get lucky that it did not fail?
    Should I try to replace the sensor?
    I also drained the oil and is all clean.

  2. #2
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,755

    Re: Crank Sensor Bad?

    Originally posted by Dan Lewis
    I have a 92 SC and from all I've seen on this subject is just about every time a crank sensor goes out, the harminoc balancer is damaged beyond repair. In my case, the balancer, by visual inspection, appears to be OK. Did I get lucky that it did not fail?
    Should I try to replace the sensor?
    I also drained the oil and is all clean.
    You have it backwards.. whenever the harmonic balancer goes, it can sometimes cause damage to the crank sensor. The crank sensor can fail on its own without anything else happening. That is what happened to mine. Are you having a no-start and seeing the up-arrow on the tach stay lit when trying to start the car? If so, that usually means the crank sensor is bad.. usually, but not always.
    Also, during the inspection did you notice if the HB main center bolt is there?

  3. #3
    Join Date
    Nov 2002
    Location
    Phoenix, AZ
    Posts
    180
    My crank sensor problem was and is that it's just dirty. I have an oil leak from,I believe the intake, and it's running down to the crank sensor. So, I have to take the pully off now and again to clean it back up. I have to get my intake gasket replaced ASAP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •