Results 1 to 7 of 7

Thread: Ahhh HELP PLEASE!

  1. #1
    Join Date
    Jun 2003
    Posts
    8

    Unhappy Ahhh HELP PLEASE!

    Someone please help me. I put new sprak plugs in the other day and i dont know the firing order.

    Does anyone know the firing order or the way the wires are supposed to go? I dunno what to do.

    Help would be appreciated alot.

    Sorry I have posted so many times I need help and this is the only place I know of that can help.

    Thanks
    Mitchell

  2. #2
    Join Date
    Jul 2002
    Location
    Surrey, BC
    Posts
    317
    The firing order is - 1 4 2 5 3 6, seeing as you just replaced the plugs you should know that cynder 1 is at the front passenger side followed by 2 then 3, cylinder 4 is at the front of the driver side, followed by 5 then 6.

  3. #3
    Join Date
    Apr 2002
    Location
    Madison, Ohio
    Posts
    17,683
    Notice to all new posters. Please use the search function. We love to help and that is one of the reasons were are here. But you really try some people's patience because you don't use it.

    Here is a perfect link that took me all of 8 seconds to find using the search function.

    SC firing order.

    You are very welcome! Hope you get your SC back running real soon and continue to enjoy it as much as the rest of us do.

  4. #4
    Join Date
    Jun 2003
    Posts
    8

    xr7 Dave

    Thank you very much. I'm sorry that I diden't use the search. Please forgive me I will do that from now on. Once agin thank you.


    Mitchell

  5. #5
    Join Date
    Apr 2002
    Location
    Madison, Ohio
    Posts
    17,683
    You are quite forgiven. I am amazed myself sometimes at the amount of information which is already here!

  6. #6
    Join Date
    Jul 2002
    Location
    Surrey, BC
    Posts
    317
    oops, i forgot something
    the terminals on the dis module are as follows
    1 2 3
    5 6 4
    there is a very good solution to this problem for future reference, DO ONE PLUG AND WIRE AT A TIME!!!

  7. #7
    Join Date
    Jun 2003
    Posts
    8

    grrr

    that helped and they WERE in the wrong order there right now. But it still boggs down and dies for some reason. I think its the wiring because I unpluged alot of stuff to get to the plugs from up top. Now I know to jsut jack the car up and do it from under beacause its easier.


    And thanks to livin thats a very good idea



    Thanks,
    Mitchell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •