Results 1 to 7 of 7

Thread: Freak hard start getting freakier. Please........

  1. #1
    Join Date
    May 2003
    Posts
    38

    Unhappy Freak hard start getting freakier. Please........

    I posted on here a little while back about this freakish hard start................give the car electricity and have to wait between 30 seconds and 2 hours for the fuel pump to kick on. Many kind suggestions were offered and I ran with a couple......... had the relays replaced and when that didn't fix it, went and had the fuel pump replaced. Now mechanic is suggesting I go for a new "sending unit" off the fuel pump. Anybody familiar with this thing or its mystical powers or if it's likely just another couple hundred down the drain.............this fix is breaking me.

    Any thoughts will be hugely appreciated.

    Stevie

  2. #2
    Join Date
    Jun 2003
    Location
    Oregon
    Posts
    318
    Iím guessing that you cleaned out the gas tank (or checked it) and also checked the fuel lines. Does it run normal after starting?

  3. #3
    Join Date
    Jun 2002
    Location
    Grand Rapids, MI
    Posts
    1,142
    Which relay specifically did you replace. We had a similar problem on Doug Williams' car a while back. We replaced everything from the fuel pump, fuel pump relay (located in the IRCM in the newer cars), checked grounds, jumped the inertia switch in the trunk, everything. It wound up being the EEC relay in the main fuse box on the passenger side of the engine bay. Does your fuel pump turn on sometimes when you hit the key and other times not? Does it ever stall while going down the road? Any idea what kind of pressure you are running on the rail?

  4. #4
    Join Date
    May 2003
    Posts
    38
    Kevin- Not sure which relay he replaced. I will inquire.......and pass on the EEC relay experience you had to my guy. To answer your other questions. Yes, sometimes, only when the car is cold, and it's not baking hot outside the fuel pump will hit right when I turn the key; this I can hear and also triggers the check engine light in the dashboard. Only then will the car start. If I don't hear the pump kick on and see that light, she will not start. Once she starts, she's good to go. One time she stalled out after I'd fired her up............but that's once in a few hundred hits. Other than that she wont die while running. But after she warms up and I turn her off, she ain't goin' nowhere for at least two hours, until she cools down, or it cools down outside.

    Duane - I assume he checked the fuel lines and the tank but I'll confirm that too.

    Thanks guys!

  5. #5
    Join Date
    Jun 2002
    Location
    Grand Rapids, MI
    Posts
    1,142
    Sounds exactly like the problem Doug had. On a long shot if it is not that it could potentially also be the ignition switch.

  6. #6
    Join Date
    May 2003
    Posts
    38
    Yeah, you know somebody else mentioned the ignition switch to me, and it is all chawed up, but it just seems like such a strange inconsistent problem, like it must be electrical. But, it that is it, I'll get to it eventually. Thanks a lot Kevin.

  7. #7
    Join Date
    Apr 2002
    Location
    Lakeville, MN
    Posts
    13,517
    The installation walkthrough at MN12peformance.com for their fuel pump replacement kits has good pictures for you to reference so you can understand what the mechanic might be talking about:

    http://www.mn12performance.com/mn12p...it-install.htm

    Have you checked to make sure the pump will run when you short the diagnostic connector to ground as soon as you are having the problem?
    http://www.frontiernet.net/~miketoni...unfuelpump.jpg

    Using the picture above, you short the pin on the far right to ground to force the pump to run. You can use a fuel pressure gauge to see if pressure is built.

    Unfortunately the IRCM unit gets involved in this as well. So I would start by taking a hard look at the ignition switch, as well as verifying good connections on all the connectors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •