Results 1 to 5 of 5

Thread: timing question

  1. #1
    Join Date
    Oct 2002
    Location
    Destrehan, LA
    Posts
    19

    timing question

    92SC now running, but checking a while before taking out for some breakin.

    New short block from Ford. Stieg heads and cam, w/1.73 roller rockers, Bosch matched 42# inj, 87mmPro-M MAF, 85mm MP Tb, 3.5 intake tubes and K&N, ARP head studs, ported SC by MP, raised top, 190lph fuel pump, 2.5x3x2.5 exh w/o cats, raised top, MP IC kit with pusher and puller fans, 180F tstat, Magnecor wires, new plugs, mid-length headers, BHJ balancer, underdrive pulley set, 10% SC pulley, 4.2 head gaskets, and chip by APTEN. I'm sure I've forgotten something. Not yet dyno's, waiting for breakin.

    Here's a question.

    At idle of 1000rpm, we put a timing light on the engine and got firing at 18 deg BTDC.

    Just checking. Does this seem right? Nowhere do we find any reference to this. Helm manual has a 10deg BTDC as an intial timing, and states that this is not adjustable.

  2. #2
    Join Date
    Apr 2002
    Location
    Forked River, NJ
    Posts
    2,092
    You have to pull the spout connector, on the passenger inner fender, to check the base timing.

  3. #3
    Join Date
    Oct 2002
    Location
    Destrehan, LA
    Posts
    19
    thanks, DLF

    thought that's what I'd hear, as we debated about it and apparently GM LT1's have a plug that is removed to check base timing as well. Just didn't have time to search the manual thoroughly enough to confirm that the SPOUT plug has to be removed.

    At that point, I would expect about 10 deg BTDC. Will do this Monday.

    What if the base timing is not at 10? Will slight movement of the cam sensor cause a change? (I wouldn't think so, but it might). The only other thing that could affect it is the position of the crank sensor, I suppose. Great pains were taken to get the crank sensor in the correct position so it did not differ from where it was on the original balancer. So, fingers are crossed!

  4. #4
    Join Date
    Nov 2003
    Location
    Rhode Island
    Posts
    667
    The crank sensor isn't adjustable is it. I thought it just bolts right to the block and the damper air vanes pass right through it. Are you talking about the cam sensor positioning?

  5. #5
    Join Date
    Oct 2002
    Location
    Destrehan, LA
    Posts
    19
    whoops. I need to be careful with terminology. The pulse ring may be positioned incorrectly on the balancer. With BHJ, the ring has to be reomoved from the stock balancer, and placed in the saem position with respect to the crank as the OEM part.

    Unfortunately, the BHJ's timing marks won't just correspond to the OEM part. This issue was known when adding the BHJ balancer as the engine accessories were re-assembled to the short block. Lots of care was taken to make sure the pulse ring was in the correct position.

    And the crank sensor isn't adjustable, per se, as relates to crank position. I have read that the air gap is something that must be checked. I believe that is to prevent the sensor (a hall effect device) from touching the ring and getting damaged.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •