Page 1 of 4 1234 LastLast
Results 1 to 15 of 49

Thread: Pics of my latest broken engine parts

  1. #1
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,899

    Pics of my latest broken engine parts

    Last week I took the car out for a short drive and after doing a test burnout and bouncing off the rev limiter I noticed a metalic clicking noise was coming from inside the engine.

    I pulled it apart tonight and found the problem. One of the spyders that holds the lifters in place broke and allowed the lifter to turn sideways which chewed a nice rut into the cam lobe. So now it's time for another cam.

    Actually I was glad to see it was only the cam, I was pretty sure I had spun a rod bearing. Should be running in a couple weeks if I cam get another cam core.
    Attached Images Attached Images  
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  2. #2
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,899
    Here is the lifter and broken spyder.
    Attached Images Attached Images  
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  3. #3
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,899
    This is the damaged cam lobe.
    Attached Images Attached Images  
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  4. #4
    Join Date
    Nov 2003
    Location
    Lakeland, Florida
    Posts
    136
    Agh that sucks.

    Wonder if you can get some hardened spyders?

  5. #5
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,899
    And finally my lovely engine compartment...It looked so nice last week.
    Attached Images Attached Images  
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  6. #6
    Join Date
    Apr 2002
    Location
    Madison, Ohio
    Posts
    17,540
    Time for some link bar lifters....
    Quote Originally Posted by Miller View Post
    Ya thats why i tape mine down. People think its bc i dont have a moonroof seal (which is true) but its really to keep my roof from ripping off .
    Email me here.

  7. #7
    Join Date
    Apr 2002
    Location
    Thorold, Ontario, Canada
    Posts
    2,432
    how the heck do you break one of those? I haven't seen anyone break one of those before, any idea how it happened?

  8. #8
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,899
    how the heck do you break one of those?
    Beats me, maybe it was cracked from one the other 8 times I broke something in the valve train.

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  9. #9
    Join Date
    Sep 2002
    Posts
    4,850
    Dave you have no luck with the valve train there at least it was not a rod bearing like you thought it was.


    Good Luck

  10. #10
    Join Date
    Jul 2002
    Location
    NJ & FL
    Posts
    1,528
    Those pretty red things sure are fun to look at..

    Dang Dave. I bet you thought you wouldn't have to get that far into the motor again since moving away from the adjustables.

    Either way, it's always a treat to see into that thing.

    C-ya soon,
    Anthony

  11. #11
    Damn Dave that sucks! What do you plan to do about it?
    I'm never gonna get this car built if you guy's dont stop breaking stuff and skeering the dumplins out of me.

  12. #12
    Join Date
    Nov 2002
    Location
    Cresson, TX (DFW)
    Posts
    1,320
    __________________________________________________ _
    Last week I took the car out for a short drive and after doing a test burnout and bouncing off the rev limiter I noticed a metalic clicking noise was coming from inside the engine.
    -----------------------------------------------------------------------------------


    I like that line.

  13. #13
    Join Date
    Apr 2003
    Location
    VA
    Posts
    1,082
    "Get er Dun" *broke again*? Thats the story of my life there. 75% of the time Im easy on the car and something always happens when Im easy on it, NEVER when Im hard on it... So should I just drive wide open? rolleyes: I LIKE those rockers too! Do you have any dyno numbers? im curious to see what shes pushin'.

  14. #14
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,899
    Anthony,

    Those are the same adjustable rockers I had. What kept breaking every few months were the rocker studs. As you know when it broke at the Shootout last year it also bent one of the valves. Since the heads had to come off the car to fix the bent valve, I had the heads reworked to accept some much stronger Comp Cam mega studs. That part of the valve train is holding up fine.

    Mike,

    I couldn't find any reason for the lifter retainer to fail and I since it's held down with that springy peice of stamped sheet metal that allows some movement, revving it hard shouldn't have mattered. The part is a casting and the break was clean with no signs of abraision, binding or anything else that would explain the failure. It may have been dropped one of the times the engine was apart and had a crack in it.

    With the v8 turbo SC project in full swing, I don't really want to do any upgrades like the link bar lifters Dave suggested, so I'm planning to put it back together using the same style parts.

    I think it's just a case of bad luck.

    David

    PS: I NEED A CAM CORE....please contact me at dkneibert@charter.net if you have one for sale.
    Last edited by David Neibert; 03-02-2004 at 10:07 AM.
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  15. #15
    Join Date
    Apr 2002
    Location
    Madison, Ohio
    Posts
    17,540
    Check his member page.
    Quote Originally Posted by Miller View Post
    Ya thats why i tape mine down. People think its bc i dont have a moonroof seal (which is true) but its really to keep my roof from ripping off .
    Email me here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •