Results 1 to 13 of 13

Thread: Just bought a fully loaded 90 SC - have some bugs please help!!!

  1. #1
    Join Date
    Oct 2004
    Posts
    52

    Just bought a fully loaded 90 SC - have some bugs please help!!!

    Im a mustang guy btw

    Well I got the SC. Its a nice ride thats for sure, super smooth and comfy seats and it seems to go pretty good. Im just taking easy on it since its been parked for quite a while. I put in the superplus gas at petrocan (best gas they have). Didnt notice any pinging or any odd driving.

    I got a few problems though.

    When I turn on the headlights they stay on for a while then begin to flicker off to running lights then back to headlights in totally random order. Im thinking its the AUTODIM thing, where is the sensor (lazer thing?). Is there a way I can override this and dis-connect it?

    Also the stereo doesnt work. I push the power button and the radio turns on and I can hear fuzz/distortion from the speakers very slightly but no music. I try the volume knob (press up?) and it doesnt get any louder. The cd player doesnt work it seems to have no power going to it.

    Also the passenger door sags, you can pull up on the side and you can feel it lift a weebit. You have to pull up on the handle and gently close the door, then press it to close it properly.

    One more thing, I was driving it like a old man the entire time accelerating slow trying to keep the RPMs pretty much low as possible, and it seemed to shift fairly hard into gear, is that normal?

    Please help me work out these bugs!

    Thanks!!!!

    Any tips?

  2. #2
    Join Date
    Sep 2004
    Location
    Calgary, AB
    Posts
    194
    Hi Matt, I'm new too (saw you on the WC forums). But I can help a wee bit.

    "When I turn on the headlights they stay on for a while then begin to flicker off to running lights then back to headlights in totally random order. Im thinking its the AUTODIM thing, where is the sensor (lazer thing?). Is there a way I can override this and dis-connect it?"

    This from what I have read sounds like a bad headlight switch (Fords of that era would have the problem where they overheat), they should be available here and there.

    "Also the stereo doesnt work. I push the power button and the radio turns on and I can hear fuzz/distortion from the speakers very slightly but no music. I try the volume knob (press up?) and it doesnt get any louder. The cd player doesnt work it seems to have no power going to it."

    No clue, sounds like they just jammed the stuff in there and had an aftermarket one in there. Pull it out and check the wiring.

    "Also the passenger door sags, you can pull up on the side and you can feel it lift a weebit. You have to pull up on the handle and gently close the door, then press it to close it properly."

    There should be a hinge kit on Ebay that should fix that, Spinning Wheels I think had it.

    "One more thing, I was driving it like a old man the entire time accelerating slow trying to keep the RPMs pretty much low as possible, and it seemed to shift fairly hard into gear, is that normal?"

    Not sure, if it's an Auto, could be a shift kit. My car has a shift kit and the shift into 2nd is really hard and fast.

  3. #3
    Your headlights are most-likely a bad headlight or multi-function switch. The headlight switch was recalled many years ago because of a problem. The multi-function switch can also wear out from use. The factory fog lights are wired to the headlight switch and that causes them to wear out. I rewired mine using a relay to the ignition to aviod this from happening again. I would check both of them first.

    The stereos are also notorious for that exact behavior. I would just go aftermarket. The factory unit was decent in its day and even with the JBL system and amps it is substandard.

    The door hinges also can start sagging. You can get replacement hinges from many sources to cure that also.

    The AOD tranny is not the greatest and usually last about 75,000 miles and needs to be rebuilt. I am on my second one and have 147,000 miles on the car. A shift kit helps cure some of the woes and I highly recommend if you do a rebuild in the future that you add one. BTW a shift kit will make it shift firmer so maybe that is what you are experiencing.

    Hope this helps.

  4. #4
    Join Date
    Oct 2004
    Posts
    52
    Actually Ive been told the tranny was rebuilt not too long ago.

    Is the door hinge kit a universal type or what?

    About the headlights, my foglights do not work, dont know if its the bulbs or what. Our our headlights 9007? And where is this headlight switch located, you dont mean the actual knob do you?

    Thanks!

  5. #5
    Join Date
    Apr 2002
    Location
    Vernon, BC
    Posts
    1,926
    Hey Matt, I am from the WC board also

    our headlights have 9005/9006 bulb sets with the fog lights bein 880's

    The headlight switch is behind the knob. IF you take off the one dash piece you will see the headlight switch assy. The multifunction switch is the one coming out of the column that also does the wipers etc

  6. #6
    Join Date
    Oct 2004
    Posts
    52
    Quote Originally Posted by Tazer999
    Hey Matt, I am from the WC board also

    our headlights have 9005/9006 bulb sets with the fog lights bein 880's

    The headlight switch is behind the knob. IF you take off the one dash piece you will see the headlight switch assy. The multifunction switch is the one coming out of the column that also does the wipers etc
    Okay, any chance that you think that might be effecting my foglights. And like mentioned it does seem that once my headlights are on for a bit and they 'wars up' that is when they start to act up.

    So I get it from ford? If it was a recall do I still have to pay?
    (EDIT FOUND THIS ON EBAY: http://cgi.ebay.com/ebaymotors/ws/eB...category=34202 WILL THAT WORK FOR ME?)



    ALSO about the door hinge kit, I cant find anything on ebay? Any other pins that will work or can I Get any thing from ford or a local parts dealer? any other suggestions?

    thanks!!
    Last edited by Matt94GT; 10-03-2004 at 02:35 AM.

  7. #7
    Join Date
    Aug 2003
    Location
    Cary, North Carolina
    Posts
    5,075
    Quote Originally Posted by Matt94GT
    Okay, any chance that you think that might be effecting my foglights. And like mentioned it does seem that once my headlights are on for a bit and they 'wars up' that is when they start to act up.

    So I get it from ford? If it was a recall do I still have to pay?
    (EDIT FOUND THIS ON EBAY: http://cgi.ebay.com/ebaymotors/ws/eB...category=34202 WILL THAT WORK FOR ME?)



    ALSO about the door hinge kit, I cant find anything on ebay? Any other pins that will work or can I Get any thing from ford or a local parts dealer? any other suggestions?

    thanks!!

    You can get a headlight switch from the parts store, no need to go to ford for that one. The fog lights are tied into the headlight system. They go off when high beams are on. Get the headlights working and then figure out the fog lights. The headlight switch gets too much voltage causing it to get hot and over time it just gets to where the contacts don't make good contact.

    I rewired my foglights independent of the headlights using the stock fog light switch and also replaced the headlight switch.


    David

  8. #8
    Join Date
    Oct 2004
    Posts
    52
    So if I were to buy a new headlight switch that would solve the overheating problem (and solve my headlight problem if that is the case)?

    Do you think that link on ebay that I posted above will work?

    Still cant find anything about were to buy the door pins


    Thanks for all the help!

  9. #9
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,648
    Quote Originally Posted by Matt94GT
    So if I were to buy a new headlight switch that would solve the overheating problem
    Ummm.. don't get your hopes up on that one.

  10. #10
    Join Date
    Oct 2004
    Posts
    52
    Quote Originally Posted by TbirdSCFan
    Ummm.. don't get your hopes up on that one.
    but it will probaly help? I dont even use my foglights...

  11. #11
    Join Date
    May 2003
    Location
    western Washington
    Posts
    146
    Quote Originally Posted by Matt94GT
    but it will probaly help? I dont even use my foglights...

    Matt, the headlight switch has a built-in circuit breaker. It is shown in the factory wiring diagrams. It cycles the headlights on and off as it gets overloaded. Using high output headlamps can aggravate the switch, but the
    bimettallic element used for the circuit breaker just ages in many cases. Personally, I took the switch apart and soldered the damn thing together. I have my electrical circuits fused elsewhere anyway. There are two switches for the TBird/Cougar series....with or without AutoLamp.

    Also, it's a good idea to feed the foglight circuit through its own wiring. It lowers the amperage running through the headlamp switch and the foglights don't go out when you switch to high beam...and you can run your fog lights together with your parking lights for a unique appearance.

    The lower door hinges are interchangeable left to right. They are easy to pull from the wrecking yard. Passenger doors usually are in better shape than the driver's side. Strange that your passenger side was worse than the driver's side....It's not a right hand drive, is it?

    Hard shifting AOD trans can be caused by misadjusted throttle cable. The adjust procedure is the same for ALL Ford automatics of that era. That would be the first thing to check...before you go tearing into the unit. Browse through a Chilton or Haynes book at the local parts house for an illustration.

    hope that helps a bit

    david

  12. #12
    Join Date
    Jun 2003
    Location
    Vancouver, Washington USA
    Posts
    1,740

  13. #13
    Join Date
    Oct 2004
    Posts
    52
    thanks people!!

Similar Threads

  1. Just bought a '90 35th edition
    By svopaul in forum New SC Owner Forum
    Replies: 17
    Last Post: 06-07-2004, 05:14 PM
  2. not sure of year SC I bought...help w/ obd-I swap
    By John68 in forum Technical Forum
    Replies: 22
    Last Post: 03-15-2004, 11:59 PM
  3. Just bought set of 35th front seats( new in box)
    By thunderstruck in forum Non Technical Forum
    Replies: 8
    Last Post: 12-19-2002, 10:50 PM
  4. Just bought ... Some questions
    By Billabong089 in forum New SC Owner Forum
    Replies: 13
    Last Post: 12-08-2002, 11:51 PM
  5. So I finally bought a '90 SC Off another board member
    By syphon in forum New SC Owner Forum
    Replies: 3
    Last Post: 09-14-2002, 04:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •