Page 1 of 3 123 LastLast
Results 1 to 15 of 42

Thread: new best et's......today

  1. #1
    Join Date
    Apr 2002
    Location
    Philly
    Posts
    2,421

    new best et's......today

    I went to Maple Grove Raceway in PA today the last test and tune. I waited in line for 2.5 hours for my first run. I got in the staging lanes at 10am when they started. Every other run somebody was gerenating someone. I have now come to hate idiots who think their car can shift at 10 grand and stay together. You name the car it blew up....Ricers, rotary motors, Rustangs. Attached are my two slips from today. The only problem I was really having was the car was shifting into OD at 1000' and I had the car in drive.
    Attached Images Attached Images   
    1992 Thunderbird SC
    13.322 @ 102.81
    1993 Thunderbird SC 5spd..white
    2002 F350 SD Diesel (SC tow vehicle)

  2. #2
    Join Date
    Jun 2002
    Location
    Adrian, Michigan
    Posts
    1,358
    It's about time you got your SC into the 13's Ken. 13.63 @ 94.85mph is damm good, especially with your car shifting into O.D. Your E.T. and mph don't seem to match up..is it because of shifting into O.D? With that E.T. you'd think at least a 98-99 mph would accompany it.
    SCCoA Member # 490 since 1997
    1995 SC (five speed) 12.8913@105.86
    Best 60' 1.7489

    1994 SC (automatic) 13.4829@100.23mph
    Best 60' 1.8539 On a stock long block with bolt on's
    http://www.sccoa.com/forums/garage.p...ge_view&id=638

  3. #3
    Something wrong with that track? Are you below sea level?

    Does your speedometer match roughly with the trap speed reported. A 1.9 sec 60' time is respectable but even so how are you getting a 13.6 on that trap speed? You seem to be going .5 sec quicker than the mph would equate to.



    Jerry

  4. #4
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,902
    Congrats Ken. BTW, The numbers look fine to me...mine used to run 13.8 @ 94 on street tires.

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  5. #5
    Join Date
    Jan 2004
    Location
    new york city
    Posts
    1,147
    thats a great 60foot you got there

  6. #6
    Join Date
    Aug 2002
    Location
    North Georgia
    Posts
    766
    Quote Originally Posted by Shockwave
    Something wrong with that track? Are you below sea level?
    i dont recall the actual level, but when i was at maple grove, the DA was 1270ft above sea level.

    Thats a nice track... and nice times! Shifting into O/D was definetely killing your mph and probably a couple hundredths.

  7. #7
    Join Date
    Apr 2002
    Location
    Philly
    Posts
    2,421
    Quote Originally Posted by Jimmy 2Coupes
    It's about time you got your SC into the 13's Ken. 13.63 @ 94.85mph is damm good, especially with your car shifting into O.D. Your E.T. and mph don't seem to match up..is it because of shifting into O.D? With that E.T. you'd think at least a 98-99 mph would accompany it.
    Jimmy,
    I believe my times and mph should be better. When the shifts into OD, you can feel it slow down. I am looking at getting a lentech valve body over the winter. I rode in a couple of cars with them. I love their shifts.
    Thanks
    Ken
    1992 Thunderbird SC
    13.322 @ 102.81
    1993 Thunderbird SC 5spd..white
    2002 F350 SD Diesel (SC tow vehicle)

  8. #8
    Join Date
    Apr 2002
    Location
    Philly
    Posts
    2,421
    Quote Originally Posted by Shockwave
    Something wrong with that track? Are you below sea level?

    Does your speedometer match roughly with the trap speed reported. A 1.9 sec 60' time is respectable but even so how are you getting a 13.6 on that trap speed? You seem to be going .5 sec quicker than the mph would equate to.



    Jerry
    Jerry,
    The track is above sea level. The previous et's were 14.3 @ 97. I know my time slip looks funny but with it shifting into OD it kills my mph and et
    Thanks
    Ken
    1992 Thunderbird SC
    13.322 @ 102.81
    1993 Thunderbird SC 5spd..white
    2002 F350 SD Diesel (SC tow vehicle)

  9. #9
    Join Date
    Apr 2002
    Location
    Philly
    Posts
    2,421
    Thanks everyone for the nice comments, now have to change the oil and wash the car for storage.
    Thanks again
    Ken
    1992 Thunderbird SC
    13.322 @ 102.81
    1993 Thunderbird SC 5spd..white
    2002 F350 SD Diesel (SC tow vehicle)

  10. #10
    Join Date
    Oct 2002
    Posts
    988
    I haven't been to Maple Grove in a while. Nice times though, you ever go down to Cecil?

  11. #11
    Join Date
    Apr 2002
    Location
    Philly
    Posts
    2,421
    Quote Originally Posted by 1FASTSC
    I haven't been to Maple Grove in a while. Nice times though, you ever go down to Cecil?

    I have been down to Cecil for at least two years.
    1992 Thunderbird SC
    13.322 @ 102.81
    1993 Thunderbird SC 5spd..white
    2002 F350 SD Diesel (SC tow vehicle)

  12. #12
    Join Date
    Jun 2002
    Location
    Orem, UT
    Posts
    5,902
    Nice times Ken.

    Was that 04 Cobra stock?? If he could get a better 60 ft. he'd be in the 12's.

    Also do you have a transgo shift kit? I had one before I got my lentech valvebody and the car would shift into OD also like yours. When I installed the Lentech I checked the TV cable and it was way loose, surprisingly I never cooked this tranny. I tightened it up and now I get 3rd gear rubber at 1/4 throttle.
    Scott Long
    1992 SC 5-speed
    Black on black leather, lowered, 18x9 Chrome Saleens...

  13. #13
    Join Date
    Apr 2002
    Location
    Philly
    Posts
    2,421
    Quote Originally Posted by Scott Long
    Nice times Ken.

    Was that 04 Cobra stock?? If he could get a better 60 ft. he'd be in the 12's.

    Also do you have a transgo shift kit? I had one before I got my lentech valvebody and the car would shift into OD also like yours. When I installed the Lentech I checked the TV cable and it was way loose, surprisingly I never cooked this tranny. I tightened it up and now I get 3rd gear rubber at 1/4 throttle.
    Scott,
    The 04 Cobra look stock. His mph should be 12's easily.


    Yes, I still have a transgo shift kit. I had my tv cable adjusted about a year ago. I am buying a lenctech valve body over the winter with OD delete setup.
    Ken
    1992 Thunderbird SC
    13.322 @ 102.81
    1993 Thunderbird SC 5spd..white
    2002 F350 SD Diesel (SC tow vehicle)

  14. #14
    Join Date
    Jun 2002
    Location
    Orem, UT
    Posts
    5,902
    I really like my lentech, it took some getting used to though. It shifts pretty hard at light throttle since I have the TV set at max. If I keep the gas down enough to keep the boost gauge at 0 it will chirp 3rd gear around 30 mph. At 5 psi it won't, but on the floor it will. Its weird like that. But I love being able to feel it shift and I always know what gear I'm in. Plus I just love the look on peoples faces when I get 2nd and 3rd gear rubber or pass them at 70 and chirp the upshift into 3rd....

    Should knock a tenth or two since it is shifting faster.

    Mine shifts at light throttle like this:

    1st to 2nd at 12-15 mph, 2nd to 3rd at 28-30 mph, and 3rd to OD at 53-55 mph if I let up on the gas, or if I stay on it more it will shift around 70-75 mph. If I'm on the floor it holds 3rd to redline.

    My transgo would shift 1-2 at 10 mph, 2-3 at 20 mph, and 3-OD at 45mph. It would kick out of OD at 45 also. My lentech will hold OD to 40 if you keep minimal pressure on the gas, but if you go 1/4 throttle or more under 45mph it goes back to 3rd. My transgo would shift 3-OD while in D and it had me scared I was going to hurt the trans. Although I found out my TV had a lot of slack but I had already sold my transgo modified valve body by the time I found that out so hopefully the new owner sets the TV like I told him and he might not experience that problem. Other than that the transgo was ok, but its a whole new car with the lentech.
    Last edited by Scott Long; 11-07-2005 at 11:36 AM.
    Scott Long
    1992 SC 5-speed
    Black on black leather, lowered, 18x9 Chrome Saleens...

  15. #15
    Join Date
    Jun 2004
    Posts
    68
    Quote Originally Posted by Ken Seegers
    I went to Maple Grove Raceway in PA today the last test and tune. I waited in line for 2.5 hours for my first run. I got in the staging lanes at 10am when they started. Every other run somebody was gerenating someone. I have now come to hate idiots who think their car can shift at 10 grand and stay together. You name the car it blew up....Ricers, rotary motors, Rustangs. Attached are my two slips from today. The only problem I was really having was the car was shifting into OD at 1000' and I had the car in drive.
    ken shift it manual and u will hit around 100 u know the 1 to D back to 1 back into drive

Similar Threads

  1. Heard from Calvin today, it's bad, may need our help.
    By Vernon in forum Super Coupe Club of the Gulf Coast
    Replies: 29
    Last Post: 10-06-2005, 03:59 AM
  2. Heard from Calvin today, it's bad, may need our help.
    By Vernon in forum Non Technical Forum
    Replies: 18
    Last Post: 09-07-2005, 12:07 AM
  3. I hit the jackpot today :)
    By unclenick in forum Super Coupe Club of Florida
    Replies: 19
    Last Post: 09-05-2005, 01:15 AM
  4. Drove the car for the first time today! FINALLY!!!
    By V6Sprout in forum Super Coupe Club of Ontario
    Replies: 1
    Last Post: 08-30-2003, 11:33 AM
  5. Bought some Iridium plugs today
    By V6Sprout in forum Super Coupe Club of Ontario
    Replies: 8
    Last Post: 08-12-2002, 10:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •