Page 24 of 24 FirstFirst ... 142021222324
Results 346 to 354 of 354

Thread: Autorotor answers

  1. #346
    Join Date
    Sep 2004
    Location
    Indy
    Posts
    5,621
    Quote Originally Posted by T-bird4vr
    Randy, why does it say autorotor upside down?

    I bet you can fix that.
    I asked also, but there wasn't an answer.
    1994 SC
    4.5L Twin Turbo SVO
    Project GTFD

  2. #347
    Join Date
    Apr 2002
    Location
    Karns, TN
    Posts
    1,328
    Quote Originally Posted by CMac89
    I asked also, but there wasn't an answer.
    The AR is normally positioned so that the outlet points down not up.
    1989 Cougar XR7 - [I]Modified[/I]
    1967 Cougar XR7 - untouched -
    2011 F350 Crew Cab Superduty FX4
    6.7 diesel 435hp/800 ft lbs torque
    2010 Harley Davidson Ultra Classic
    1965 Factory Five Challenge Road Race Cobra

  3. #348
    Join Date
    Apr 2002
    Location
    Madison, Ohio
    Posts
    17,532
    Ya, I was PO'd when I saw that too but there is nothing that can be done other than maybe put a nice sticker over it.
    Quote Originally Posted by Miller View Post
    Ya thats why i tape mine down. People think its bc i dont have a moonroof seal (which is true) but its really to keep my roof from ripping off .
    Email me here.

  4. #349
    Join Date
    Apr 2002
    Location
    Home of the Whopper
    Posts
    3,415
    Do you guys really care if it says AR upside down? So I guess no one will be retrofitting any M112's cause they might say Eaton upside down....gasp. Small potatoes.

    Back to the 4.6L intake dyno test. Are you talking about the upper intake or the lower intake? I know C&L makes a new cast upper intake which is basically just an elbow that connects the TB to the lower intake. If they dyno tested this and got 12 HP....I would be happy with that considering it's like a $250 piece and a breeze to install.

    Micah

  5. #350
    Join Date
    Sep 2002
    Location
    Effingham.IL
    Posts
    5,011
    Earlier in this thread I posted, I was having some noise come from my new MPIII.

    Turned out to be a bearing going bad on the jackshaft to blower
    tention idler pulley.

    But I would like to get some tighter couplers, that would run with a little
    less noise.

    Sorry for bad mouthing the MPIII before I checked a little closer.

    Thanks Randy

  6. #351
    Join Date
    Nov 2004
    Location
    butler pa
    Posts
    1,926
    Quote Originally Posted by Randy N Connie
    Earlier in this thread I posted, I was having some noise come from my new MPIII.

    Turned out to be a bearing going bad on the jackshaft to blower
    tention idler pulley.

    But I would like to get some tighter couplers, that would run with a little
    less noise.

    Sorry for bad mouthing the MPIII before I checked a little closer.

    Thanks Randy
    very upstanding randy, I have a friend that has a MPIII that also complained about the marbles sounds. Turns out the blower pulley was loose!

  7. #352
    Join Date
    Apr 2002
    Location
    Home of the Whopper
    Posts
    3,415
    And I must admit, the music sound that my mp3 was emitting....was actually music!

    Micah

  8. #353
    Join Date
    Nov 2002
    Location
    Columbus, Ohio
    Posts
    6,924
    Quote Originally Posted by XR7 Dave
    Ya, I was PO'd when I saw that too but there is nothing that can be done other than maybe put a nice sticker over it.
    Dave, if its alright I am going to call you tonight at 6pm when I am off work about possibly getting an AR.

    Shane

  9. #354
    Join Date
    Aug 2002
    Posts
    3,659
    Quote Originally Posted by Micahdogg
    And I must admit, the music sound that my mp3 was emitting....was actually music!

    Micah
    oh your such a funny guy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •