Results 1 to 6 of 6

Thread: Need help

  1. #1
    Join Date
    Feb 2006
    Posts
    8

    Need help

    My radiator recently blew when i was driving it. I replaced it with an all alluminum radiator. The car now just turns over but will not start. It has spark and fuel flow. I even shot starter fluid in it and it still will not start what could be a possible fault?

  2. #2
    Join Date
    Nov 2005
    Location
    Marysville, Washington
    Posts
    778
    is there gas in it ?

  3. #3
    Join Date
    Sep 2003
    Location
    BUFFALO, NY
    Posts
    532
    We're Going To Need More Info Than That... Did You Keep Driving It After The Radiator Blew (aka Overheat), Did You Remove Anything Else During The Radiator Install That You May Have Forgotten, Etc.....

  4. #4
    Join Date
    Feb 2006
    Posts
    8
    The car stalled after the radiator blew and i got it towed home. Theres gas in it, everythings connected but still wont start.

  5. #5
    Join Date
    Feb 2003
    Location
    Westerly, RI
    Posts
    243
    Quote Originally Posted by red92tbirdsc
    The car stalled after the radiator blew and i got it towed home. Theres gas in it, everythings connected but still wont start.
    Check your crank sensor. If coolant got on it, it could have damaged it.

  6. #6
    Join Date
    Sep 2003
    Location
    BUFFALO, NY
    Posts
    532
    When I Had My Car Towed, The Tow Truck Driver Set The Car Down Alittle Hard And Tripped The Fuel Pump Shut Off Switch. Its A Red Button In The Drivers Side Panel Of The Trunk. See If You Can Here The Fuel Pump Turning When You To The Key To The Run Position.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •