Results 1 to 1 of 1

Thread: bad booster, or bad line lock perhaps???

  1. #1
    Join Date
    Jun 2002
    Location
    North Alabama
    Posts
    2,623

    bad booster, or bad line lock perhaps???

    Here is some back matter, started new cause that thread got kinda stale
    http://www.sccoa.com/forums/showthread.php?t=81662

    Basically, I had sudden degradation in braking and I've got the non-abs tbird booster/crown vic MC setup with PBR mustang calipers and a biondo line lock...
    During some aggressive braking, I got what I thougt was brake fade. The pedal travel seemed OK, maybe a little light, but not spongy, and the last 10% or so of pedal travel seemed to go to the floor without adding the last 10% of braking.


    Anyways, a couple of more hours at it this evening, and I am now thinking that the booster is bad, like mechnically. I say this becasue I bled the mess outta the brakes again and adjusted the booster pushrod a few times and still felt about the same... I'm wondering if perhap the mechanism hat attaches the brake pedal rod to the actual pushrod somehow got dislodged?

    Until the last test drive, it was still acting the same, I couldn't even get em to lock up unless i was going slow, like 20-30 MPH and slammed the mess out of em. Just before I got back to the house I heard/felt a small click/minor pop at the stop sign and the brakes started draggin really bad! So I had to drive darn near a mile to the house with what felt like half the brake pedal depressed, sopping a few times to let em cool a little. All four were smokin' when i got back to the house...

    So I don't know if maybe it wasn't engaging the MC right or what? Another possibility it that perhaps the line lock was stuck half open or something because now that I think about it, it seemed like I had full travel of the pedal, absolutely no air in the lines that I could find, and I had a brand new MC which I bench bled when I installed. Calipers are also fairly new.

    So I am wondering if maybe I should call/email the line lock folks to see if this might have been an indication of a stuck line lock or somehting???

    The pedal did get all the way to the floor when I had the problem, but it was pretty much already this way when it was working fine earlier; but when the magic "fix happened", the pedal would barely go down after whatever it was corrected itself... I call it a magic fix because I prolly had the booster rod too far out at this point and I assume if I shorten it back to where it used to be it would work fine again????

    Any ideas?
    Last edited by sizemoremk; 09-20-2006 at 11:52 PM.

Similar Threads

  1. Is there a tool for the clutch line?
    By GooeyGus2 in forum Technical Forum
    Replies: 14
    Last Post: 11-22-2005, 07:41 PM
  2. theoretical possibilities of line lock
    By James Kanteraki in forum Technical Forum
    Replies: 1
    Last Post: 07-17-2003, 08:32 AM
  3. Collapsed vac line to boost gauge...what can i do?
    By Mike Manzo in forum Technical Forum
    Replies: 3
    Last Post: 04-27-2003, 12:37 PM
  4. Replies: 3
    Last Post: 10-30-2002, 06:03 PM
  5. Line lock?
    By fastsc92 in forum Technical Forum
    Replies: 0
    Last Post: 09-26-2002, 10:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •