Results 1 to 9 of 9

Thread: Can't figure it out!! Help!

  1. #1
    Join Date
    Jan 2007
    Posts
    7

    Can't figure it out!! Help!

    I am trying to put together an 89 supercoupe that has been apart for 5 years or so. Everything has gone well so far but now I am stuck with one engine harness connection. I can't figure out where to connect the harness that connects the passenger side O2 sensor, oil level sensor, and knock sensor to the main harness or wherever it connects. It is a male rectangular grey plug. Not sure if I am missing part of the harness or just can't see where it goes. I'm sure its simple but I have looked at it for hours. If anybody can help me out that would be awesome.

  2. #2
    Join Date
    Jul 2004
    Location
    Salt Lake City, Utah
    Posts
    1,519
    The female plug is mounted on the right frame rail at a point 1" below the radiator overflow tank. The harness for the female plug branches off from the harness that runs on top of the frame rail. The branch-off point is 3" forwards of the overflow tank.

  3. #3
    Join Date
    Jan 2007
    Posts
    7
    Thanks for the info J.D. Unfortunately I still can't find it. The only branch just ahead of the overflow tank goes up to the overflow tank sensor and the maf sensor. There is another further ahead but its for the fan motor. There is a connector that branches off further back behind the overflow tank that hangs parallel to the shock tower. Only thing is is that its the exact same male connector as the one I need to plug in. I just figured it was for an auto trans because it doesn't look like its ever been plugged in to anything. I attached a couple pictures. Hopefully someone can make sense of this and give me some insight on what I am missing.
    Attached Images Attached Images   

  4. #4
    Join Date
    Jul 2004
    Location
    Salt Lake City, Utah
    Posts
    1,519
    Here's a picture from my car:
    Attached Images Attached Images  

  5. #5
    Join Date
    Jan 2007
    Posts
    7
    Wow it doesn't get any clearer than that. I guess I will have to take a real close look. Thanks J.D!!

  6. #6
    Join Date
    Jan 2007
    Posts
    7
    Well I took a closer look and found nothing. As you can see in the first pic I had posted its just not there. Is there any harness differences between 1989 and 1991 that I am missing. J.D what year is your car?? If anybody can confirm the location of this harness on different year sc's it might give me more answers. Does anybody know what the rectangular male connector hanging parallel to the shock tower is for? This harness thing is driving me crazy.

  7. #7
    Join Date
    Aug 2004
    Location
    Que. Canada
    Posts
    326
    it has to be your car cause i just checked all 3 of my SC's(89,90 xr7's and a 91 SC) to make sure and there are all in the place J.D. said.you may have to check furthur back on the harness.

  8. #8
    Join Date
    Jan 2007
    Posts
    7
    I guess I will look elsewhere on the harness. Thanx phyxius for checking out your cars.

  9. #9
    Join Date
    Jan 2004
    Location
    Outside KC MO
    Posts
    5,791
    Dude...it probably fell behind the mounting bracket if it was not hooked up or stuck in place. Look from under the car since it comes off of the starter harness (so it appears on my car).

    Chris

Similar Threads

  1. Something the mechanic can't figure out...
    By 93DirtyBird in forum Technical Forum
    Replies: 33
    Last Post: 01-31-2007, 11:21 AM
  2. How to figure out pulley size for boost..
    By CHADD in forum Technical Forum
    Replies: 7
    Last Post: 11-29-2005, 12:27 AM
  3. Still Detonating: can't figure it out
    By tbirdboy in forum Technical Forum
    Replies: 8
    Last Post: 06-24-2003, 07:20 PM
  4. cant figure this out
    By ZOOMBUGGY3 in forum Technical Forum
    Replies: 4
    Last Post: 11-18-2002, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •