Page 1 of 2 12 LastLast
Results 1 to 15 of 23

Thread: SC problems

  1. #1
    Join Date
    Apr 2006
    Posts
    55

    SC problems

    HEy. I have been on the forums a while now, been looking into getting me a SC. I found one near me, a lady is asking $1200 for it. It looks good in and out, and runs great but it has a few problems I was hopeing you guys/gals could help me with. 1st problem is the brake pedal is very stiff, it feels like they are not beeing power assisted. It runs great, we ran it up the road and back, and it runs like a top, minus 2nd gear, sencros are gone. But, she said after about 30miles of driving it will start to feel like it is running out of gas, and the boost guage will jump around and the tach will act funny. Then after about 5 minutes it will clear out and run fine. What could be causing the problem with the brakes and power loss? I would really like to get the car if these are not going to be too hard to fix.

    Thanks for any help in advance

    Chase

  2. #2
    Join Date
    Mar 2003
    Location
    Edmonton, Alberta Canada
    Posts
    3,062
    Chase,

    The brakes could be the result of a few things. Is the ABS light on? Is it flashing?

    My car had stiff pedal with no brakes and it was an ABS relay on the passenger firewall. On some cars the accumulator on the brake assembly goes bad.

    The other problem may be the DIS. Those are the symptoms my brother's car had at first. Progressively got worse to where it always ran like it was out of fuel. Replaced the DIS and it ran like new again.

  3. #3
    Join Date
    Apr 2006
    Posts
    55
    With these problems does this car sound worth $1200. Also, about how much is a DIS and is it easy to replace?
    Thanks
    Chase

  4. #4
    Join Date
    Jul 2005
    Location
    Palos Heights
    Posts
    2,347

    S.c.

    At $1,200.oo it sounds good to me.

    Change the DIS module?...........about ten maybe fifteen minutes start to finish.

    Cost?, around $120.oo to $150.oo depending where you go.

    Try Advance Auto Parts online, I got mine there.

  5. #5
    Join Date
    Apr 2006
    Posts
    55
    OK. So DIS is the ignition module? I work at Advance Auto, so I get a 20% discount on anything in the store. I looked last night at work and didnt see anything labled DIS so I wasnt sure what exactly I needed to look for.
    Thanks for the help so far, I think I will call her today and set up a day to go get it.
    Chase

  6. #6
    Join Date
    Aug 2003
    Location
    Cary, North Carolina
    Posts
    5,075
    I would say since you are probably gonna need a new DIS and maybe some brake work, offer her a grand and see if she'll take it.

  7. #7
    Join Date
    Oct 2004
    Location
    Charlotte, NC
    Posts
    8,159
    Quote Originally Posted by funkbuster View Post
    OK. So DIS is the ignition module? I work at Advance Auto, so I get a 20% discount on anything in the store. I looked last night at work and didnt see anything labled DIS so I wasnt sure what exactly I needed to look for.
    Thanks for the help so far, I think I will call her today and set up a day to go get it.
    Chase
    Look under ignition modules for thunderbird SCs......

    They should have a picture of the module.....

  8. #8
    Join Date
    Apr 2006
    Posts
    55
    ok. I will try that. Also, with the brakes. How expensive is the accumulator and how hard would it be to replace. The pedal hardly gives any and it takes the car a while to slow down. That is the main reason I didnt pick it up yesterday, I think I should trailer it home so I dont wreck it before I make it back.
    Thanks
    Chase

  9. #9
    Join Date
    Aug 2003
    Location
    Cary, North Carolina
    Posts
    5,075
    If it's the accumulator ball, try www.priorreman.com

  10. #10
    Join Date
    Oct 2004
    Location
    Charlotte, NC
    Posts
    8,159
    I just bought and accumulator ball from Prior for my XR-7.......

    $110.00 shipped.....

    Before you get the accumulator, check the following.....

    Make sure the pump motor is operating correctly.....

    Sometimes the pump motor seal will fail and let brake fluid into the motor housing......

    This causes corrosion and locks up the pump motor (I've had three of them, so far).....

    With the key off, pump the brake pedal 10 - 15 times and then turn the key on but do not start the engine.....

    You should hear the pump motor run for about 20 - 30 seconds and then it will LOAD UP and shut off.....

    If your pump motor isn't running, apply direct current to it and see if that makes it run....

    If that works, then you probably have a bad relay on the passenger side firewall.....

  11. #11
    Join Date
    Apr 2006
    Posts
    55
    update:

    I pumped the pedal around 15-20 times with the key off. Turned the key on and you can hear the pump activating. It runs for a few seconds, then it shuts off. When it shuts off, you can feel it "pop" and you can feel this in the brake pedal. Also, the ABS light is on for a breif second when you start the car then it shuts off. Also, the switches in the driver's door werent hooked up, so I pulled the door panel off today, and the passenger window, and locks work, but the driver window wouldnt. I messed around and found 5 plugs in the door until I finally found 2 that match, pluged them in and the drivers window started working. I let it set there while I did some running. Got home, and now the darn thing wont budge. Any ideas?

    Thanks for the help so far.
    Chase

  12. #12
    Join Date
    Apr 2007
    Location
    New Orleans, LA
    Posts
    1,975
    could be the driver side switch going bad... remove the driver side switch and jump off the terminals see if it works.. could just be the switch going out

  13. #13
    Join Date
    Apr 2006
    Posts
    55
    OK. Today I drove the car around for a while. When I first got in it, the driver's side window switch was working. Car drives like a champ, only main problem with daily driving it is the brakes. Car only has 99k on it. I would really like to get these brakes fixed, kinda sux not being able to drive the car to its full pontential.
    Last edited by funkbuster; 05-03-2007 at 08:26 PM.

  14. #14
    Join Date
    Oct 2004
    Location
    Charlotte, NC
    Posts
    8,159
    Sounds like the pressure switch is bad......

    After working on these troublesome units, I feel it is easier to just delete the whole system and go with a conventional braking system......

    I am doing it on my silver 92 this weekend.....

  15. #15
    Join Date
    Apr 2006
    Posts
    55
    how hard is that and what does it include doing?

Similar Threads

  1. Intermittent problem(s)
    By anejr in forum Technical Forum
    Replies: 8
    Last Post: 09-18-2007, 12:43 AM
  2. sc problems
    By PilotYFZ in forum Technical Forum
    Replies: 4
    Last Post: 08-30-2006, 07:30 PM
  3. Replies: 7
    Last Post: 10-02-2004, 01:02 AM
  4. POP UP problems?
    By vettewars in forum Non Technical Forum
    Replies: 10
    Last Post: 07-26-2004, 03:31 PM
  5. Idleling problems, We added alot of HP to our SC
    By victor malvar in forum Super Coupe Club of Florida
    Replies: 4
    Last Post: 11-03-2003, 03:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •