Results 1 to 4 of 4

Thread: Freestar brakes

  1. #1
    Join Date
    Aug 2003
    Location
    Cary, North Carolina
    Posts
    5,075

    Freestar brakes

    My wife was in a little bumper thumper recently in her Freestar. She was stopped behind a BMW suv and glanced up and saw it moving forward and thought the light had changed. (this is why I don't let her drive my SC, although she did drive it to class today, because of the brakes on the Freestar)

    So she gassed it and then noticed the light hadn't changed, but she ended up getting on the brakes hard and still bumped the Beemer. Now the rear brakes were making a loud squalling sound, which has turned into a scrubbing sound.

    Is it possible that the brakes didn't release all the way and the pads have been up against the rotors, wearing them out? Could the anti-lock system have been messed up?

    Anyone had a brake problem like this before??? Any help will be greatly appreciated. I need to get it fixed, so she doesn't need to drive mine.

  2. #2
    Join Date
    Apr 2002
    Location
    Caledon, Ontario ... CANADA !!!
    Posts
    7,586
    Premature brake wear on the rear of the Freestars has been an issue, you're not the only one seeing that. Ford has updated rear pads for them, but I can't say for sure how much of an improvement they are.


    cheers
    Ed N.

  3. #3
    Join Date
    Aug 2003
    Location
    Cary, North Carolina
    Posts
    5,075
    Thanks Ed. I was always thinking the front brakes went first, since they do more of the stopping. The thing only has 56,000= and I thought it was early for the rear brakes to go. Guess I'll be doing the brakes on it.

  4. #4
    Join Date
    Apr 2002
    Location
    Caledon, Ontario ... CANADA !!!
    Posts
    7,586
    David, I've seen them in our shop with less than 50,000 km needing rear brakes ... that's around 30,000 miles.


    cheers
    Ed N.

Similar Threads

  1. Brakes Again
    By Carlit0way in forum Technical Forum
    Replies: 4
    Last Post: 10-15-2008, 11:54 PM
  2. Power brakes failed
    By 91ScDrIvEr in forum Technical Forum
    Replies: 1
    Last Post: 11-14-2005, 09:22 PM
  3. Mark VIII Torque Convertor & Cobra Brakes
    By Thomas A in forum Parts for Sale
    Replies: 6
    Last Post: 10-05-2005, 02:10 PM
  4. Spongy Brakes Problem
    By Lugen in forum Technical Forum
    Replies: 4
    Last Post: 06-26-2002, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •