And the fun ends abruptly....

SuperChicken89

SCCoA Member
Can check my pile of SC parts to see if I still have an OEM cat but won't have a chance till Saturday. I believe we used my old down pipes for the other bad cat.

Bryan
 

onequiksc

Registered User
Brakes went out again today in the driveway...

Thankfully it happened there and not when I went to get gas in the car the other day.

For now, that's the 1st priority, the cat and the rest will have to wait...Ugghh
 

kamakazie_1

Registered User
Your part is still in the truck Dan, It looks new, I will get with Joyce and see about coming up that way on Sunday.. If not I'll come up that way..

RJ
 

onequiksc

Registered User
RJ, I can probably get down to you on Sunday, I don't expect you to have to do the legwork on my purchase...not that I don't appreciate it mind you, I just feel I should be spending the gas $$$.

I will text or phone you Sunday and see what's up with your schedule. If we can't make it work I am pretty sure I can run down during the week if you leave it somewhere I can grab it.

Then again, I will have to find time to pull the old unit out first, so it's not like I can't wait till next weekend or later...the car's not going anywhere anytime soon.
 

kamakazie_1

Registered User
No big deal bud, it's not like you are 100 miles away or anything... I'm thinking Joyce is going to want to do Daytona Sunday anywhere so I'm like real close to you by then.. We'll see what happens tomorrow bud..

RJ
 

onequiksc

Registered User
Got the whole Y pipe section out of the parts car today, everything went pretty easily. Cut the pipe at the rear of the resonator, so if other options aren't as simple, it should hook up to my pipe at the same place with an adapter or small pipe section.

Question; This Y pipe has 1 oxygen sensor on the pass. side pipe, forward of the cat, the driver's side has it in the engine manifold and isn't on the driver's side pipe at all...is that the same as the oem setup?

I don't feel like jacking up my SC to look at the moment, been under a car too much today already...
 

Kurt K

SCCoA Member
It's been a long time since I had stock exhaust, but I believe the driver side O2 either goes in or right before the CAT.
 

onequiksc

Registered User
Thx Kurt...here is a pic from today...I will get under mine in the next week and hope you're correct on that, but I seem to remember noticing that as well...otherwise I would have to fabricate an O2 bung in this units D/S pipe...being that Adam had stock exh. manifolds on his car, I think that has to be right...my exhaust isn't rusty like this (Aluminized pipe on mine) so i'd prefer just trying to make that D/S Cat work with my setup, but I'll take the path of least resistance regardless of the rust if that's how it shakes out...

 
Last edited:

Kurt K

SCCoA Member
Dan,

That doesn't look like stock exhaust to me. The stock driver side CAT actually comes in the top and discharges in the back. That said, it's possible that the O2 threads into the stock manifold.
 

onequiksc

Registered User
Kurt, just a misunderstanding, I mentioned earlier in the thread that my parts car is Adam's old car ( which this part came off of) and that his exhaust/cats are aftermarket / fabricated differently than my stock system, so yes, I am aware of that.

My concern was how to make either his D/S cat work on my oem system or to just hang his whole Y piece on mine.

One way of the other I can, the 02's were my only real concern...
 

onequiksc

Registered User
Still at the shop unfortunately Angelo, playing the waiting game once again...will post when I get it back, Thx.
 

SuperChicken89

SCCoA Member
Dan... FYI... I checked my 89 parts pile and I still have the driver side cat from my orignal exhaust. It is yours if you want it. I also have your old passenger side cat... though it is a ~~~ :D

Bryan
 

Brad Klein

Registered User
why put cats on it? do you have inspections? I know the State doesn't do them but I know some counties do but if yours doesnt just take them off Ive been cat free since 97 with no issues
 

onequiksc

Registered User
Thx Bry, I like Brad's idea (it had crossed my mind-no inspections here in Volusia) but I will discuss with you when I get the car back and do whatever is easiest.

Thanks for that heads- up Brad :)
 

SuperChicken89

SCCoA Member
Taking the cats off will make it louder. Didn't think you wanted it louder because you put rear mufflers back on it a few years ago. My car is catless with a Magnaflow 2-in2-out center muffler and Borla's out back. It is very loud when you stand on the loud peddle. :D

If it were me, I would put the setup from Adam's car on because the factory cat setup is very restrictive. Just my $.02 :D

Bryan
 

onequiksc

Registered User
Just spoke to Kenny, the M/C from Angelo does not work...


RJ, I called Angelo and told him, he said you have another M/C on a car you have, and he said if we can power that car up with a battery we can find out if that unit works or not.

I can come down this weekend if possible and rip it out if it does..

This is really getting old...
 
Last edited:

S_Mazza

Registered User
Just spoke to Kenny, the M/C from Angelo does not work...


RJ, I called Angelo and told him, he said you have another M/C on a car you have, and he said if we can power that car up with a battery we can find out if that unit works or not.

I can come down this weekend if possible and rip it out if it does..

This is really getting old...

What does it mean that the MC doesn't work? Motor doesn't run?

Did you test for power at the motor connector? Fuses good?
 
Top