Blower motor

DOUG H

SCCoA Member
What year? Manual or Auto climate controls?
The blower motor does does turn on, but blows cold?
Trying to understand what your issue is?

I think you mentioned in another post the car was a recent
purchase & you hadn't purchased any manuals for it yet?
A copy of EVTM especially if you plan on keeping it
 

Matt’s94sc

Registered User
What year? Manual or Auto climate controls?
The blower motor does does turn on, but blows cold?
Trying to understand what your issue is?

I think you mentioned in another post the car was a recent
purchase & you hadn't purchased any manuals for it yet?
A copy of EVTM especially if you plan on keeping it
94 auto it’s digital if that helps
 

DOUG H

SCCoA Member
So if you have digital ATC (Automatic Temp Control) or ECC (Electronic Climate Control) I think people
call them different things, the most common failure on this system is the blower speed control module
which is in the blower housing beside the blower motor( same place the blower resister would be on a manual
heater system) 5 wire connector on it & is known for melting. Last time I bought 1 it was over $300.00 cndn.
If you want to find used Crown Vic & Grand Marquis are different but 91-99 Explorer & Mountaineer are the
same.

If you release the 2 tabs on glovebox door & let it flip down you can see it pretty clearly.
 

Matt’s94sc

Registered User
Ok thank you very much for your time I will be looking into it. The blower motor randomly turned on yesterday and has been fine so far
 

35th

Registered User
Almost sounds as if maybe the blower motor itself is going bad if it where the resistor block then you would loose a fan speed but it wouldn't just come back I know my work van would do that periodically and one day it said no more so I replaced it bren fine since also had the same issue on my 97 tbird lx
 
Top