Electrical Issues

Ifrit

Registered User
Seems like I am posting a lot more this year and we are back with a new problem.

On the drive home I noticed two things, when starting my car my aftermarket radio had lost all its settings but the car clock was ok, and that my car was charging lower than normal, sitting around 14.3-14.4v when it would normally charge at 14.7-15.0v. after sitting at a light and started to move through for my turn the car started to surge. The best way I can explain what I experienced was like the car was rapidly losing all power amd regaining it. Pulled over on the side of the road turned on the hazards and shut off the car. When I shut off the car it lost all power, no hazards or anything. Turned the key back to accessory and lights came back and my battery was sitting at 11.4v.

Opened the hood to poke around and the lights went out again. Inspection of the fuse box on the driver side showed 1 melted 30A fuse (pink/red). Power came back on on its own when I was speaking with a local SC guy. Pulling and putting the fuse back in seemed to do nothing. Decided to try and start the car, it started and ran as i limped it home. On the rest of tye way home charging dipped as low as 13.8v

So im going to guess I have 2 issues, 1 is alt and the other I am unsure. The car was running a higher out alt which was why I charged at 15v and because of this my battery light is always on.

Any help like normal is appreciated.
 

Attachments

  • IMG_20200503_102507_01.jpg
    IMG_20200503_102507_01.jpg
    483.9 KB · Views: 71

KMT

Registered User
Sounds like the multi-wire ignition switch under the dash on the steering column cratered. Best to inspect closely, might want to spend the $ and just replace if it's years old, etc.

I would disconnect the battery before handling it, tho...while being aware that something else may have taken a hit, such as the wiring below the box, leading to that fuse. Lift and check. Keep a fire extinguisher handy ;)
 

Ifrit

Registered User
Sounds like the multi-wire ignition switch under the dash on the steering column cratered. Best to inspect closely, might want to spend the $ and just replace if it's years old, etc.

I would disconnect the battery before handling it, tho...while being aware that something else may have taken a hit, such as the wiring below the box, leading to that fuse. Lift and check. Keep a fire extinguisher handy ;)

I will take a look and source a replacement. any way to tell if it is bad or anything else I can look into?
 

KMT

Registered User
They tend to come open with use as a common problem...lots of tension internally. Look to see if the halves are separating, might need to turn the key to exercise to see, but again, unless you know it's newish, the cost is low enuf and they are easy to source, AutoZone, etc. Avoid Dorman...

s-l225.jpg
 

Ifrit

Registered User
They tend to come open with use as a common problem...lots of tension internally. Look to see if the halves are separating, might need to turn the key to exercise to see, but again, unless you know it's newish, the cost is low enuf and they are easy to source, AutoZone, etc. Avoid Dorman...

s-l225.jpg


Would a failure in this switch really result in a complete loss of power to the car though? even without my key in the car the hazards should still function, unless this model controls more then ignition related things.
 

KMT

Registered User
According the my '90 EVTM, that switch is upstream of the following:
  • blower
  • turn
  • HEGO
  • Run
  • Anti-lock
  • Cluster
  • PDB/coil
Just trying to give you something common/easy to look at/place to start. Can't debug more from here ;)
 

Ifrit

Registered User
Right I just remembers something else that was strange about the car, that morning and on the way home the car had developed an electrical whine in the audio speakers. This after market system does have isolation inline for each speaker so if any whine is getting through it has to be a lot or a very bad ground fault.
 

Ifrit

Registered User
I finally got around to swapping the switch and at the current time I am unsure if this corrected the issue as the problem will randomly crop up. In the mean time I am wanting to chance the alternator whine that has developed in my speakers. If anyone has the locations / pictures of all major grounds in 94/95 that would be a major help in finding / cleaning all grounds in the car.
 
Top