Inconsistent Boost

35th

Registered User
So still working out issues with the 90 SC 5sp I'm noticing that sometimes I get betwee 13-15lbs of boost (when the car is running good) sometimes I get over 15lbs off the gauge(running terribly when that happens) it does have a 10% SC pully but any thoughts on what else would be causing it to shoot boost so high that it's got more air than fuel (is my assumption of what's happening) and idles at around - 20 or so
 

sam jones

Registered User
Good morning


Here are some suggestions.

Do the scan for codes. Correct any defects.

Clean the MAF sensor.

Check the following:

Fuel pressure. When was the fuel filter last changed?

Wobble at the harmonic balancer pulley.

Evidence of coolant leaking on crankshaft sensor.

Spark plug wires for damage/serviceability at the plugs and at the ignition coil pack.

Supercharger belt rubbing against the cam sensor/DIS connector harness.

DIS module for compromised heat sink. DIS harness connectors (black/gray) for corrosion.

PCV components for serviceability.

Battery negative cable to engine mount and radiator support for security and or corrosion.
 

35th

Registered User
No relevant codes I do get codes for clutch switch(never had one on the car since I bought it) and egr (also never had one) I got a canister purge fault (first time that's came up) bhj balancer less than 5k on plugs, wires, fuel filter, fuel pump, maf, air charge, dis moduel, crank sensor, cam sensor, iac, coolant sensor, computer, no coolant on or around crank sensor no rubbing from belts to wires good soild grounds. All problems where present from day 1 with this car
 

35th

Registered User
Good fuel pressure no obvious issues with pcv its been replaced no vacuum issues most if not all vac hoses have been replaced
 

David Neibert

SCCoA Admin
So still working out issues with the 90 SC 5sp I'm noticing that sometimes I get betwee 13-15lbs of boost (when the car is running good) sometimes I get over 15lbs off the gauge(running terribly when that happens) it does have a 10% SC pully but any thoughts on what else would be causing it to shoot boost so high that it's got more air than fuel (is my assumption of what's happening) and idles at around - 20 or so

Please describe running terrible. If it's bucking or misfiring it's probably ignition, if it's bogging it's usually a fuel issue. Warmer weather or either supercharger belt slipping would cause a reduction in boost, but about the only thing that will cause an increase is colder weather.

David
 

35th

Registered User
So when it runs terrible rpms don't build smoothly lots of jerking and if you hold it long enough you'll hear knocking sounds but before knocking but high boost very little power I'd say roughly 50% less power than the first 2 minutes of driving
 

David Neibert

SCCoA Admin
So when it runs terrible rpms don't build smoothly lots of jerking and if you hold it long enough you'll hear knocking sounds but before knocking but high boost very little power I'd say roughly 50% less power than the first 2 minutes of driving

Sounds like something with the ignition. Only thing missing from the list of replacement parts is the coil pack. Suggest finding a good used one to install and if that helps or fixes it, buy a new Motorcraft one. I would avoid the Screamin Demon brand because many people have had problems with them.

David
 
Last edited:

MadMikeyL

SCCoA Member
A misfire would cause a temporary boost spike. Your problem is likely ignition related, and the boost spike is a symptom, not the cause.
 

35th

Registered User
I THINK... I might have figured it our did a bunch of searching on here and found a post about spark gap with higher boost so I replaced my ngk iridium. Gap .55 with autolite copper gap to. . 35 and so far has fixed the issue so we will see in the upcoming days how it works but thank everyone who has been responding to this and every other post.
 
Top