Temp will slowly creep and creep up until it’s maxed out over like 45 min drive

Driznaster

Registered User
I had an issue of my sc getting hot over about 45 min drive on highway it cools down when sitting for about 2 -3 min back to a little more than norm fan works Tstat opens and closes with heat and cooled down no bubbles in reservoir I took to a shop and they looked at some stuff but refused service and said they don’t think hg is blown because no smoke no bubbles in reservoir so now I’m trying to figure out this problem it’s not always hot maybe a little more than normal just driving local but far drives are scary any ideas would help
 
Ive had issues with my factory fan, I installed a pusher fan as an emergency backup for just in case.

You may want to test to see how accurate your temp gauge is. Possibly using one of those laser thermometers and/or installing another temp gauge that tells you exactly how hot your coolant is.
 
I suspect the rad (tubes) is plugged internally. Lots of airflow at highway speeds, but the coolant flow through rad is restricted at sustained higher rpm's, due to build up & it cant transfer heat to the fins.
 
I suspect the rad (tubes) is plugged internally. Lots of airflow at highway speeds, but the coolant flow through rad is restricted at sustained higher rpm's, due to build up & it cant transfer heat to the fins.
yeah I believe this could be it when it gets pretty warm my top hose swells a little which leads me to believe there is a blockage of some kind in the rad
 
Ive had issues with my factory fan, I installed a pusher fan as an emergency backup for just in case.

You may want to test to see how accurate your temp gauge is. Possibly using one of those laser thermometers and/or installing another temp gauge that tells you exactly how hot your coolant is.
i can check on the outside of the hoses with the laser ir thermometer but I think Doug h is onto something with clogged rad
 
Back
Top